EQWatcher Evolution > Installation > System Requirements


While I cannot say exact minimum specifications that are supported, EQWatcher should be fine with: